1
Vote

PageTypeBuilder 2.0.0 referring wrong EPiServer*.dll versions

description

Hi.

We found that PTB 2.0.0 is referring the EPiServer*.dlls of version 6.0.530.0 (CMS 6), not 6.1.379.0 (CMS 6 R2). This can easily be solved in a web project, by adding binding redirects in web.config to the R2 versions. However, in a non-web project, we were unable to achieve the same through app.config or similiar, getting this error message in VS2010 when building a Release version: "Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information"

Solution:
  • Download the PageTypeBuilder source code, change the references to point to version 6.1.379.0, and compile!
I'm suggesting that the updates should be done to the PageTypeBuilder Source code as well.

file attachments

comments